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1. Introduction 

The aim of this course is to allow you to use the various Stock Technical Indicators and create an 

Automated Stock Trading System using Microsoft Excel. We assume that you have some basic 

knowledge of Excel and is interested in putting into practice the financial concepts of a technical 

stock trading system.  

We will start from downloading Stock data and move into the calculation of the different Technical 

Indicators. The Technical Indicators include Moving Average, Directional Movement, Directional 

Movement Indicator, Average Directional Movement Index and Average True Range. The focus is 

on two aspects. The first is the understanding of the specific Technical Indicators and the second is 

the implementation of the indicators in Excel.   

We do not guarantee that you will get rich by going through these materials but we are confident 

that you will become a better technical trader as you will be able to apply many of these Technical 

Indicators to analyse your portfolio. 
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2. Download Stock Trading Prices 

 

2.1 Download Data from Yahoo Finance  

Launch Microsoft Excel and create a new workbook. You may call your workbook 

DownloadData.xls. We are going to provide the information to Excel where to download the stock 

information.  

Excel 2003: Click on Data->Import External Data->New Web Query 

Excel 2007: Click on Data->From Web 

A Mini Browser will appear. Browse to http://finance.yahoo.com. On the top left hand corner, it 

allows you to Get Quotes. Enter “YHOO” for the stock price of Yahoo. A summary of the Stock 

price for Yahoo will appear. Click on the “Historical Prices” 

Alternatively, once you are comfortable, the next time you can just simply enter full URL, 

appended with the Stock Code as follows  http://finance.yahoo.com/q/hp?s=YHOO 

On the web page you will be able to select download prices based on the following frequency 

 Daily 

 Weekly 

 Monthly 

 Dividends Only 

You can leave the defaults and click on the Get Prices.  

 

 

 

 

 

 

 

http://finance.yahoo.com/
http://finance.yahoo.com/q/hp?s=YHOO
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Click on the 3rd Yellow Arrow to turn it into a check mark, and then click the Import button. The 

“Import Data” dialog will appear,  you can click on the Properties button on this dialog to alter the 

import properties. 
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Click the OK button to close the dialog and you will see the following in Excel. The actual data 

might be different from the screen shown below as you will be importing the latest data. The 

following is captured during the 2nd of September 2008. 
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Instead of downloading the data through the steps above, an alternative is to launch your browser 

and navigate to http://finance.yahoo.com/q/hp?s=YHOO. Click on the link as shown below 

“Download To Spreadsheet” to download the entire data to Excel.  

 

 

2.1.1 Sort the Data 

You can also sort the data to display the latest stock prices on top or at the bottom of the 
spreadsheet.  
 
Excel 2003: Click on Data->Sort to sort by the Column “Date” with the data in “Ascending” order. 
 
 
Excel 2007: Click on Data->Sort and specify the options as shown below to sort the data from “Oldest 
to Newest”. 
 

 

 

 

http://finance.yahoo.com/q/hp?s=YHOO
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2.2 Automating the download of Stock Prices 

The methods above are useful when you are exploring what kind of data to download to Excel. 

However it will be laborious to go through all the steps to download the price of a specific Stock 

symbol. This section will show you how to automate the download of the Stock Prices. We will be 

using a simple programming language called Visual Basic for Applications (VBA). If you will like to 

find out more about VBA, you will be interested to know that spreadsheetml.com offers a VBA 

course on our website. Otherwise, please be assured that we will be going through the steps, one 

at a time to allow you to construct the models without prior knowledge of VBA. 

Launch Excel and create a new workbook. Call this workbook AutomatedDownloadData.xls. 

In Microsoft Excel 2003: Go to Tools->Macro->Visual Basic Editor 

In Microsoft Excel 2007: Go to Developer->Visual Basic 

Right click on VBAProject (your Excel Filename) and select Insert->Module. A default Module1 will 

be inserted. Click on Module1 and paste the VBA code below on the right hand side of the Visual 

Basic Editor. The following VBA codes allow you to download data from Yahoo Finance based on a 

specified Stock symbol, Start Date and End Date. 

Sub GetStock(ByVal stockSymbol As String, ByVal StartDate As Date, ByVal EndDate As Date) 
     

    Dim DownloadURL As String 

    Dim StartMonth, StartDay, StartYear, EndMonth, EndDay, EndYear As String 
    StartMonth = Format(Month(StartDate)-1, "00") 
    StartDay = Format(Day(StartDate), "00") 
    StartYear = Format(Year(StartDate), "00") 
     
    EndMonth = Format(Month(EndDate)-1, "00") 
    EndDay = Format(Day(EndDate), "00") 

    EndYear = Format(Year(EndDate), "00") 
    DownloadURL = "URL;http://table.finance.yahoo.com/table.csv?s=" + stockSymbol + "&a=" + 
StartMonth + "&b=" + StartDay + "&c=" + StartYear + "&d=" + EndMonth + "&e=" + EndDay + 
"&f=" + EndYear + "&g=d&ignore=.csv" 
     
    With ActiveSheet.QueryTables.Add(Connection:=DownloadURL, Destination:=Range("$A$1")) 

        .FieldNames = True 

        .RowNumbers = False 
        .FillAdjacentFormulas = False 
        .PreserveFormatting = True 
        .RefreshOnFileOpen = False 
        .BackgroundQuery = True 
        .RefreshStyle = xlInsertDeleteCells 

        .SavePassword = False 
        .SaveData = True 
        .AdjustColumnWidth = True 
        .RefreshPeriod = 0 
        .WebSelectionType = xlSpecifiedTables 
        .WebFormatting = xlWebFormattingNone 
        .WebTables = "20" 

        .WebPreFormattedTextToColumns = True 
        .WebConsecutiveDelimitersAsOne = True 

        .WebSingleBlockTextImport = False 
        .WebDisableDateRecognition = False 
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        .WebDisableRedirections = False 

        .Refresh BackgroundQuery:=False 
    End With 

    ActiveWindow.SmallScroll Down:=-12 
    Columns("A:A").TextToColumns Destination:=Range("A1"), DataType:=xlDelimited, _ 
        TextQualifier:=xlDoubleQuote, ConsecutiveDelimiter:=False, Tab:=True, _ 
        Semicolon:=False, Comma:=True, Space:=False, Other:=False, FieldInfo _ 
        :=Array(Array(1, 4), Array(2, 1), Array(3, 1), Array(4, 1), Array(5, 1), Array(6, 1), _ 
        Array(7, 1)) 

    Columns("A:F").EntireColumn.AutoFit 
End Sub 
 
Sub Download() 
     Call GetStock("YHOO", "02/01/2007", "09/05/2008") 
End Sub 

 

 
 
Click on Save and then File->Close to return to Microsoft Excel. In Excel, try out the downloading of 
data by going to  
 
Excel 2003: Go to Tools->Macro->Macros…, select the Download macro and click run 
Excel 2007: Go to Developer->Macros, select the Download macro and click run.  

 
and press the Enter key. This will initiate a download of Stock Prices from Yahoo! Finance. 
 
What we have is a subroutine that downloads stock data automatically and can be executed by Excel. 
It takes “stockSymbol”, “StartDate” and “EndDate” as parameters. 
 
In the whole block of code above, the most important line is the following.  
 

 
With ActiveSheet.QueryTables.Add(Connection:=DownloadURL, Destination:=Range("$A$1")) 
 

 
It basically says that we will be downloading data from DownloadURL and placing the result into the 
cell A1. The DownloadURL is constructed based on the parameters explained below. 
 
http://table.finance.yahoo.com/table.csv?s=YHOO&a=01&b=01&c=2007&d=08&e=05&f=2008&g=d&i
gnore=.csv  
 

 “s=YHOO” means to download the stock prices of Yahoo. YHOO is the stock symbol of 
Yahoo. 

 “a=01&b=01&c=2007” specifies the start date in Month, Day, Year. You might have noticed 
that the month is subtracted with 1, which is the format required by Yahoo. 

 “d=08&e=05&f=2008” specifies the end date in Month, Day, Year. You might have noticed 
that the month is subtracted with 1, which is the format required by Yahoo. 

 
Save this workbook as we will be using it for our next section. 
 
 
 
 
 
 
 
 

http://table.finance.yahoo.com/table.csv?s=YHOO&a=01&b=01&c=2007&d=08&e=05&f=2008&g=d&ignore=.csv
http://table.finance.yahoo.com/table.csv?s=YHOO&a=01&b=01&c=2007&d=08&e=05&f=2008&g=d&ignore=.csv
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3. Moving Average Trends 

 
Many successful investors and traders make use of trends to profit from the market, and Moving 

Average is one of the most important methods for identifying market trends. The stock prices for 

successive periods are used for the calculation of a moving average. Moving average reduces the 

effects of short term volatility and allows the investors or traders to see the underlying trends of a 

market. 

 

The aim of this section is to allow you to calculate simple moving average using Excel and make 

use of Moving Average Crossover to determine buy / sell signal and resistance level in a stock. 

After that,  the simple moving average will be expanded with Welles Wilder method of moving 

average, Directional Movement and Average Directional Movement Indicators. Welles Wilder is the 

founding father who had introduced many of the modern trend concepts in his book New Concepts 

in Technical Trading System.   

 

3.1 Simple Moving Average 

 
A moving average reduces the effect short term price volatility. For example, a 10 day simple 

moving average of the closing price is calculated by averaging the closing price of the last 10 days.  

 

Simple Moving Average = Sum(Closing Price of Last 10 Days)/10 

 

Applying this simple concept, let's go to our Excel file to calculate the following 

 

 10 Day Moving Average 

 14 Day Moving Average 

 20 Day Moving Average 

 30 Day Moving Average 

 

3.1.1 10 Days Moving Average 

Open the AutomatedDownloadData.xls in Excel. Save it as a new workbook call it 

MovingAverage.xls. Run the Download macro if the data has not yet been downloaded. Remember 

to sort the data based on Date from Oldest to Newest (or in Ascending order for Excel 2003).   

 

Next, we are going to calculate a 10 Day Moving Average. Follow the steps below: 

 

1. Click on the Cell H11.  

2. Type in “=ROUND(AVERAGE(E2:E11),2)”. This will calculate the average (of ten values of 

the closing price) from row 2 to row 11 of column E and round them to 2 decimal places.  

3. Drag this cell downwards to the end of the Stock Prices.  For Excel 2003, copy this cell (we 

are actually copying the formula of this cell) drag a range downwards to the last value of 

the Stock Prices, and paste it.  

4. Go to Cell H1, and type in “10 Day SMA” 

 

3.1.2 14 Days Moving Average 

Next, we are going to calculate the 14 Day Moving Average. Follow the steps below: 
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1. Click on the Cell I15.  

2. Type in “=ROUND(AVERAGE(E2:E15),2)”.  This will calculate the average (of fourteen 

values of the closing price) from row 2 to row 15 of column E and round them to 2 decimal 

places. 

3. Drag this cell downwards to the end of the Stock Prices.  For Excel 2003, copy this cell (we 

are actually copying the formula of this cell), drag a range downwards to the last value of 

the Stock Prices, and paste it.  

4. Go to Cell I1, and type in “14 Day SMA” 

 

3.1.3 20/30 Days Moving Average 

 

Repeat the above steps for column J and column K for the 20 days/30 days moving average. 

 

3.1.4 Charting the Moving Average 

Select the 10 Days SMA column and 
 
Excel 2003: Go to Insert->Chart, and select Line as the Standard Types, and click the Next button 
repeatedly until the dialog closes. 
 
Excel 2007: Go to Insert->Line. Choose the first line graph. You will be getting a graph like below. 
 
You will be able to change the X-Axis to date. We will leave that as an Exercise for you. 
 

 

 

Repeat the above steps for the 14 / 20 / 30 Days SMA. Alternatively, you may create a chart to 
display the moving average together with the actual closing price, in a single graph in order to 
compare them. At this point, you will be able to apply the concepts of the Moving Average trends 
mentioned in the various Financial Technical Indicators papers. 
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3.2 Using the Moving Average 

Compare a 10 day versus a 20 day moving average. One uses 10 values to compute the average 
while the other uses 20 values.  
 
A 20 day moving average gives you less fluctuation and sees the underlying trend more clearly. 

However it does not mean that the 20 day average is better. Imagine that you are going to 
calculate the moving average for a new day, the 20 day moving average includes more values in 
its averaging, and thus, might be slower to respond to changes compared to the 10 day one. So if 
a trend is reversing, you will be able to see it faster in the 10 day moving average. However,  
sometimes, the reverse trends in the 10 days moving average might be a false signal. 
 
If you overlap the different moving averages in a single graph, notice 

 
 A support level usually occurs when two moving averages cross / intersects each other. 
 When the shorter (faster changing) moving average crosses above the longer (slower 

changing) one, it usually means a rising trend of the prices. 
 When the shorter (faster changing) moving average crosses below the longer (slower 

changing) one, it usually means a declining trend of the prices. 

 Moving average is actually a mean of the price, thus when the actual price deviates too far 
from its moving average, it will typically start moving back (tends) towards the moving 
average.  

 
 

3.3 Wilders Moving Average 

A new trading day simple moving average is calculated by dropping off the earliest trading day's 
price. This can cause a problem if the recent price data shows little changes. This is not acceptable 

to some traders or analysts. On the other hand, it is also often argued that the recent prices are 
often the most important in identifying trends.  

 
Wilders devised a simple mechanism to overcome the above problem. This is done by taking into 
account previous days moving average and also placing more weight on the recent prices.   
 
Launch Excel and load the MovingAverage.xls workbook. Remove the charts and save the 

workbook as Wilders.xls. 
 
Wilder's Current Day Moving Average = (Previous Day Wilder's Moving Average * (n-1) 
+ Current Day Price)/n 
 
We are going to calculate a 14 Days Wilder’s Moving Average. 

 
1. Copy the value from Cell I15 to the Cell L15. We are initializing the first Wilder’s Moving 

Average with the value of a Simple Moving Average.  

2. Click on Cell L16. Type in “=ROUND((L15*13+E15)/14,2)”.  

3. Drag Cell L16 downwards to the end of the Stock Prices.  For Excel 2003, copy this cell (we 

are actually copying the formula of this cell), drag a range downwards to the last value of 

the Stock Prices, and paste it. 

4. Go to Cell L1, type in “Wilder’s MA” 
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3.4 True Range 

 
If in a new trading day, a stock start it's trading at a higher or lower price than the previous day's 
closing price, then a gap is said to have occurred. Welles Wilder feels that this gap needs to be 
taken into account when measuring fluctuations.  
 
The True Range of a stock price (as defined by Wilder) will need to take into account the gaps. He 

thus suggests True Range to be calculated as the Greatest number among the following values: 
 

 Difference between the current High and the current Low 
 Absolute difference between the current High with the previous Close 
 Absolute difference between the current Low with the previous Close 

 
Open the Wilders.xls file, launch the Visual Basic Editor, and key in the following into Module1. 
 

Function TrueRange(ByVal high As Double, ByVal low As Double, ByVal previousclose As Double) 
As Double 
 
Dim returnValue As Double 

diffHighLow1 = Math.Abs(high - low) 
diffHighLow2 = Math.Abs(high - previousclose) 
diffHighLow3 = Math.Abs(previousclose - low) 
 
If (diffHighLow1 > diffHighLow2) Then 
    returnValue = diffHighLow1 
Else 

    returnValue = diffHighLow2 
End If 
 

If (diffHighLow3 > returnValue) Then 
    returnValue = diffHighLow3 
End If 

 
TrueRange = returnValue 
 
End Function 
 

 
1. Click on the Cell M3. 
2. Key in “=TrueRange(C3,D3,E2)”.  
3. Drag this cell downwards to the end of the Stock Prices. 
4. Click on Cell M1 and type in “Wilder’s True Range” 

 
If you chart the Wilder’s Moving Average and Wilder’s True Range, the following is what you will be 

getting. 
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3.5 Average True Range 

 
The Average True Range is calculated as the average of the True Ranges using Wilder's method of 

moving average. The Average True Range is not used to predict prices but for determining the 
daily activity level of a stock. Low Average True Range indicates a stock is trading within narrow 
ranges without much swing while High Average True Range indicates period with sharp swings of 
prices. 
 

1. Click on the Cell N3. 
2. Key in “=TrueRange(C3,D3,E2)”. We initialize the first True Range to be our first Average 

True Range. Some technical analysts will initialize the first value with a 14 Day Simple 
Moving Average of the True Range. 

3. Click on the Cell N4. 
4. Type in “=ROUND((N3*13+M4)/14,2)”. 
5. Drag this cell downwards to the end of the Stock Prices. 
6. Click on Cell N1 and type in “Wilder’s Average True Range” 

 

You can proceed to chart out the Average True Range versus the True Range. 
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3.6 Directional Movement 

 
Wilder compares the stock trading range of the current day and previous day, and use them to 
measure trend. If the current High is higher then the previous day High then a Positive Directional 
Movement is said to have occurred. If the current Low is lower then the previous day Low then a 

Negative Directional Movement is said to have occurred.  If both Positive and Negative Directional 
Movement occurred, then the bigger of the two is taken. During days when the trading range is 
within the previous day range, it is considered to have no Directional Movement.  
 
Using the Wilders.xls file, launch the Visual Basic Editor. Key in the following into Module1. PDM 
stands for Positive Directional Movement while NDM stands for Negative Directional Movement. 
 

 

Function PDM(ByVal high As Double, ByVal low As Double, ByVal previousHigh As Double, ByVal 
previousLow As Double) As Double 
Dim highdifference As Double 
Dim lowdifference As Double 

 
highdifference = 0 
lowdifference = 0 
 
If (high > previousHigh) Then 
    highdifference = high - previousHigh 
End If 

 
If (low < previousLow) Then 
    lowdifference = previousLow - low 
End If 

 
If (highdifference > lowdifference) Then 
    PDM = highdifference 

Else 
    PDM = 0 
End If 
 
End Function 
 

Function NDM(ByVal high As Double, ByVal low As Double, ByVal previousHigh As Double, ByVal 
previousLow As Double) As Double 
Dim highdifference As Double 
Dim lowdifference As Double 
 
highdifference = 0 

lowdifference = 0 

 
If (high > previousHigh) Then 
    highdifference = high - previousHigh 
End If 
 
If (low < previousLow) Then 
    lowdifference = previousLow - low 

End If 
 
If (lowdifference > highdifference) Then 
    NDM = lowdifference 
Else 
    NDM = 0 

End If 
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End Function 

 

Click on Save and then File->Close and Return to Microsoft Excel. 
 

1. Click on the Cell O3. 
2. Key in “=PDM(C3,D3,C2,D2)”.  
3. Drag this cell downwards to the end of the Stock Prices. This will give us the Positive 

Directional Movement. For Excel 2003, copy this cell (we are actually copying the formula 

of this cell), drag a range downwards to the last value of the Stock Prices, and paste it. 

4. Click on Cell O1 and type in “Wilder’s PDM” 
 
 

5. Click on the Cell P3. 
6. Key in “=NDM(C3,D3,C2,D2)”.  
7. Drag this cell downwards to the end of the Stock Prices. This will give us the Positive 

Directional Movement. For Excel 2003, copy this cell (we are actually copying the formula 

of this cell), drag a range downwards to the last value of the Stock Prices, and paste it. 

8. Click on Cell P1 and type in “Wilder’s NDM” 

 
 

3.7 Directional Movement Indicator 

Positive Directional Movement Indicator is the ratio of the Average Positive Directional Movement 
to the Average True Range. Negative Directional Movement Indicator is the ratio of the Average 
Negative Directional Movement to the Average True Range. Thus whichever Directional Movement 
Indicator is larger; it will mean that the trend of the price is in the direction.  
 

First we must calculate the Wilder’s Average for both the PDM and NDM. 

 

1. Copy the value in the Cell O3 to Cell Q3. This is the first value we used for initializing the 
Wilder’s Average. Some technical analysts will initialize the first value with a 14 Day 
Simple Moving Average of the PDM. 

2. Select Cell Q4. Key in “=ROUND((Q3*13+O4)/14,2)”. 
3. Drag this cell downwards to the end of the Stock Prices. This will give us the Wilder’s Average 

Positive Directional Movement. For Excel 2003, copy this cell (we are actually copying the 

formula of this cell), drag a range downwards to the last value of the Stock Prices, and 

paste it. 

4. Click on Cell Q1 and type in “Wilder’s Average PDM” 

 
If you chart the Wilder’s PDM with Wilder’s Average PDM, the following is what you will get. 
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1. Copy the value in the Cell P3 to Cell R3. This is the first value we used for initializing the 
Wilder’s Average. Some technical analysts will initialize the first value with a 14 Day 
Simple Moving Average of the NDM. 

2. Select Cell R4. Key in “=ROUND((R3*13+P4)/14,2)”. 
3. Drag this cell downwards to the end of the Stock Prices. This will give us the Wilder’s Average 

Positive Directional Movement. For Excel 2003, copy this cell (we are actually copying the 

formula of this cell), drag a range downwards to the last value of the Stock Prices, and 

paste it. 

4. Click on Cell R1 and type in “Wilder’s Average NDM” 

 
If you chart the Wilder’s NDM with Wilder’s Average NDM, the following is what you will get. 
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3.7.1 Positive/Negative Directional Movement Indicator 

 

1. Click on the Cell S3. 
2. Key in “=ROUND((Q3/N3)*100,2)”.  
3. Drag this cell downwards to the end of the Stock Prices. This will give us the Positive 

Directional Movement Indicator. For Excel 2003, copy this cell (we are actually copying 

the formula of this cell), drag a range downwards to the last value of the Stock Prices, and 

paste it.  

4. Click on Cell S1 and type in “Positive DMI” 

5. Click on the Cell T3. 
6. Key in “=ROUND((R3/N3)*100,2)”.  
7. Drag this cell downwards to the end of the Stock Prices. This will give us the Negative 

Directional Movement Indicator. For Excel 2003, copy this cell (we are actually copying 

the formula of this cell), drag a range downwards to the last value of the Stock Prices, and 

paste it. 

8. Click on Cell T1 and type in “Negative DMI” 

 
Chart out the Positive DMI, Negative DMI and the Closing Price. Use it to analyze trends observed 
and published by the different Technical Traders or by Wilder himself. Or refer to Section 3.9 for an 
analysis of the trends. 
 

 
 

3.8 Average Directional Movement Index 

 
Directional Index (DX) is calculated as the ratio of the absolute difference between the values of 
the two Directional Movement Indicators to the sum of the two Directional Movement Indicators. 
This allows us to measure the strength of a trend. The DX will be a larger value when the price is 

moving towards one direction. The Average DX can be calculated using Wilder's Moving Average. 
This allows the fluctuations in the Directional Index to be reduced. 
 

1. Click on the Cell U3. 
2. Key in “=ROUND((ABS(S3-T3)/(S3+T3))*100,2)”. 
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3. Drag this cell downwards to the end of the Stock Prices. This will give us the Directional 

Movement Index. For Excel 2003, copy this cell (we are actually copying the formula of 

this cell), drag a range downwards to the last value of the Stock Prices, and paste it. 

4. Click on Cell U1 and type in “DX” 

5. Copy the value on Cell U3 to the Cell V3. This value is used to initialize our Wilder’s Average. 
Some technical analysts will initialize the first value with a 14 Day Simple Moving 
Average of the Directional Movement Index. 

6. Click on Cell V4 and key in “=ROUND((V3*13+U4)/14,2)”. This will give us the Wilder’s 

Average of DX. For Excel 2003, copy this cell (we are actually copying the formula of this 

cell), drag a range downwards to the last value of the Stock Prices, and paste it. 

7. Drag this cell downwards to the end of the Stock Prices. This will give us the Average 
Directional Movement Index. 

8. Click on Cell V1 and type in “ADX” 

 

 

 

3.9 Using the Indicators 

 
We now have three very useful indicators, the Positive DMI, Negative DMI and Average Directional 
Index (ADX). If the Positive Directional Movement Indicator crossover above the Negative 
Directional Movement Indicator, it meant that the price is on the upward trend, whereas when the 
Positive Directional Movement Indicator crossover below the Negative Directional Movement 

Indicator, it meant the price is on the downward trend. The Average Directional Index is used to 
indicate how strongly the price is moving towards one direction. So if the chart shows Average 
Directional Index increasing, it means the price is increasing in trend in a particular direction 

indicated by the Positive Directional Movement Indicator or Negative Directional Movement 
Indicator (whichever is larger). 
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4. What Next? 

 
We hope you have enjoyed the training so far and have gained a better understanding of several 

useful Technical Indicators. These Technical Indicators are definitely useful in the creation of an 

Automated Stock Trading System. Please also be assured that we are in the process of adding new 

materials to our website at http://www.spreadsheetml.com. 

 

If you have any comments or suggestions to help improve this document, please contact us at 

info@spreadsheetml.com.  

 

 

 

http://www.spreadsheetml.com/
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